# CVE-2023-29506: org.xwiki.platform:xwiki-platform-security-authentication-default XSS with authenticated endpoints

> Attackers can inject malicious scripts via authenticated endpoint URLs in XWiki, potentially leading to code execution or account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-jjm5-5v9v-7hx2

## What is CVE-2023-29506?

CVE-2023-29506 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 16 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Commons are technical libraries common to several other top level XWiki projects. It was possible to inject some code using the URL of authenticated endpoints. This problem has been patched on XWiki 13.10.11, 14.4.7 and 14.10.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-29506?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authentication-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 13.10.8 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 13.10.8 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.4.3 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.4.3 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.6 | 14.10 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.6 | 14.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29506?

Upgrade org.xwiki.platform:xwiki-platform-security-authentication-default to a fixed version for your release line: 13.10.11, 14.4.7 or 14.10.

## Is CVE-2023-29506 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29506 exists.

Public exploit code:

- XWiki >= 13.10.8 - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-29506.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29506 and fix it if it is affected.

What it is: CVE-2023-29506 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 16 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29506 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 13.10.8; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 13.10.8; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.4.3; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.4.3; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.6; fixed in 14.10
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.6; fixed in 14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29506/ (Markdown: https://insights.sbomify.com/CVE-2023-29506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29506
- OSV: https://osv.dev/vulnerability/CVE-2023-29506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29506/
Summaries are generated and may contain mistakes; the official description above is the record.
