# CVE-2023-29517: Exposure of Sensitive Information to an Unauthorized Actor in org.xwiki.platform:xwiki-platform-office-viewer


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-m3c3-9qj7-7xmx

## What is CVE-2023-29517?

CVE-2023-29517 is a high-severity vulnerability in Xwiki Xwiki, published on 18 Apr 2023. 

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. The office document viewer macro was allowing anyone to see any file content from the hosting server, provided that the office server was connected and depending on the permissions of the user running the servlet engine (e.g. tomcat) running XWiki. The same vulnerability also allowed to perform internal requests to resources from the hosting server. The problem has been patched in XWiki 13.10.11, 14.10.1, 14.4.8, 15.0-rc-1. Users are advised to upgrade. It might be possible to workaround this vulnerability by running XWiki in a sandbox with a user with very low privileges on the machine.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-29517?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-office-viewer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 14.0-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 14.0-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 14.5 | 14.10.1 |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 14.5 | 14.10.1 |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 2.5-milestone-2 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-office-viewer` | Maven | From 2.5-milestone-2 | 13.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29517?

Upgrade org.xwiki.platform:xwiki-platform-office-viewer to a fixed version for your release line: 14.4.8, 14.10.1 or 13.10.11.

## Is CVE-2023-29517 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29517 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29517 and fix it if it is affected.

What it is: CVE-2023-29517 is a high-severity vulnerability in Xwiki Xwiki, published on 18 Apr 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29517 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 14.0-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 14.0-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 14.5; fixed in 14.10.1
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 14.5; fixed in 14.10.1
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 2.5-milestone-2; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-office-viewer (Maven): affected from 2.5-milestone-2; fixed in 13.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29517/ (Markdown: https://insights.sbomify.com/CVE-2023-29517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29517
- OSV: https://osv.dev/vulnerability/CVE-2023-29517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29517/
Summaries are generated and may contain mistakes; the official description above is the record.
