CVE-2023-29527 Code injection from account through AWM view sheet in xwiki platform
Attackers can execute arbitrary Groovy scripts on the server by injecting code into user profiles or documents, leading to remote code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-29527?
CVE-2023-29527 is a critical code injection vulnerability in Xwiki Xwiki, published on 18 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions a user without script or programming right may edit a user profile (or any other document) with the wiki editor and add groovy script content. Viewing the document after saving it will execute the groovy script in the server context which provides code execution. This vulnerability has been patched in XWiki 15.0-rc-1 and 14.10.3. Users are advised to upgrade. There are no known workarounds for this issue.
Weakness: CWE-74
Which versions are affected by CVE-2023-29527?
2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-appwithinminutes-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-appwithinminutes-ui Maven | From 7.4.4 | 14.10.3 |
org.xwiki.platform:xwiki-platform-appwithinminutes-ui Maven | From 7.4.4 | 14.10.3 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-29527?
Upgrade org.xwiki.platform:xwiki-platform-appwithinminutes-ui to 14.10.3 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-29527 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29527 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-jgrg-qvpp-9vwr.