# CVE-2023-29659: libheif vulnerable to segmentation fault via floating point exception

> Attackers can cause a denial of service in applications using libheif by providing crafted HEIF images that trigger a floating point exception.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2023
- **Updated:** 29 Jan 2025
- **Also known as:** DEBIAN-CVE-2023-29659, GHSA-22fx-6r9m-r8h9, ROOT-OS-UBUNTU-2204-CVE-2023-29659, SUSE-SU-2023:2223-1, SUSE-SU-2023:2223-2, UBUNTU-CVE-2023-29659

## What is CVE-2023-29659?

CVE-2023-29659 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 5 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Segmentation fault caused by a floating point exception exists in libheif 1.15.1 using crafted heif images via the heif::Fraction::round() function in box.cc, which causes a denial of service.

Weakness: CWE-369 (Divide By Zero)

## Which versions are affected by CVE-2023-29659?

2 open source packages ship an affected version, including github.com/strukturag/libheif. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/strukturag/libheif` | Go | All versions | 1.15.2 |
| `github.com/strukturag/libheif` | Go | All versions | 1.15.2 |
| `libheif` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 | All versions | 1.12.0-150400.3.11.1 |
| `libheif` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP5 | All versions | 1.12.0-150400.3.11.1 |
| `libheif` | SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 1.12.0-150400.3.11.1 |
| `libheif` | openSUSE:Leap 15.4 | All versions | 1.12.0-150400.3.11.1 |
| `libheif` | openSUSE:Leap 15.5 | All versions | 1.12.0-150400.3.11.1 |

Products: Fedoraproject Fedora, Struktur Libheif.

## How do I fix CVE-2023-29659?

Upgrade github.com/strukturag/libheif to 1.15.2 or later.

## Is CVE-2023-29659 being exploited?

There is no known exploitation of CVE-2023-29659 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29659 and fix it if it is affected.

What it is: CVE-2023-29659 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 5 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-29659 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/strukturag/libheif (Go): affected all versions; fixed in 1.15.2
- github.com/strukturag/libheif (Go): affected all versions; fixed in 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29659/ (Markdown: https://insights.sbomify.com/CVE-2023-29659/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29659
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29659
- OSV: https://osv.dev/vulnerability/CVE-2023-29659

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29659/
Summaries are generated and may contain mistakes; the official description above is the record.
