{"answers":{"affected":"2 open source packages ship an affected version, including proxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-2968 in the wild and no public exploit code.","fix":"Upgrade proxy to 2.1.1 or later.","what":"CVE-2023-2968 is a high-severity denial of service vulnerability in proxy_project:proxy, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-2968 and fix it if it is affected.\n\nWhat it is: CVE-2023-2968 is a high-severity denial of service vulnerability in proxy_project:proxy, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-2968 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- proxy (npm): affected from 2.0.0; fixed in 2.1.1\n- proxy (npm): affected from 2.0.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-2968/ (Markdown: https://insights.sbomify.com/CVE-2023-2968/index.md)","id":"CVE-2023-2968","markdown":"https://insights.sbomify.com/CVE-2023-2968/index.md","name":"CVE-2023-2968","record":{"aliases":["GHSA-mj6p-3pc9-wf5m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm proxy library","requires_auth":"none","summary":"A remote attacker can cause a denial of service in the npm proxy library by sending crafted HTTP requests that trigger a TypeError due to undefined variable usage.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[{"product":"proxy","vendor":"proxy_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-232","name":"Improper Handling of Undefined Values"}],"description":"A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Undefined variable usage in npm package \"proxy\" leads to remote denial of service","id":"CVE-2023-2968","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"MindSpore json_helper.cc UpdateArray memory corruption","id":"CVE-2023-2970"},"packages":[{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"proxy","purl":null,"source":"GHSA-mj6p-3pc9-wf5m"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"proxy","purl":"pkg:npm/proxy","source":"GHSA-mj6p-3pc9-wf5m"}],"prev":{"headline":"TinyMCE Custom Styles \u003c 1.1.4 - Admin+ Stored Cross-Site Scripting","id":"CVE-2023-2967"},"products":["proxy_project:proxy"],"published":"2023-05-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-09","vendors":["proxy_project"]},"summary":"A remote attacker can cause a denial of service in the npm proxy library by sending crafted HTTP requests that trigger a TypeError due to undefined variable usage.","url":"https://insights.sbomify.com/CVE-2023-2968/"}