# CVE-2023-2968: Undefined variable usage in npm package "proxy" leads to remote denial of service

> A remote attacker can cause a denial of service in the npm proxy library by sending crafted HTTP requests that trigger a TypeError due to undefined variable usage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 9 Jan 2025
- **Also known as:** GHSA-mj6p-3pc9-wf5m

## What is CVE-2023-2968?

CVE-2023-2968 is a high-severity denial of service vulnerability in proxy_project:proxy, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.

Weakness: CWE-232 (Improper Handling of Undefined Values)

## Which versions are affected by CVE-2023-2968?

2 open source packages ship an affected version, including proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `proxy` | npm | From 2.0.0 | 2.1.1 |
| `proxy` | npm | From 2.0.0 | 2.1.1 |

Products: Proxy Project Proxy.

## How do I fix CVE-2023-2968?

Upgrade proxy to 2.1.1 or later.

## Is CVE-2023-2968 being exploited?

There is no known exploitation of CVE-2023-2968 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2968 and fix it if it is affected.

What it is: CVE-2023-2968 is a high-severity denial of service vulnerability in proxy_project:proxy, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-2968 in the wild and no public exploit code.

Affected packages and fixed versions:
- proxy (npm): affected from 2.0.0; fixed in 2.1.1
- proxy (npm): affected from 2.0.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2968/ (Markdown: https://insights.sbomify.com/CVE-2023-2968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2968
- OSV: https://osv.dev/vulnerability/CVE-2023-2968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2968/
Summaries are generated and may contain mistakes; the official description above is the record.
