# CVE-2023-2972: Prototype Pollution in antfu/utils

> Prototype pollution in antfu/utils allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-p2fh-2h23-6grg

## What is CVE-2023-2972?

CVE-2023-2972 is a medium-severity vulnerability in antfu/utils, published on 30 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Prototype Pollution in GitHub repository antfu/utils prior to 0.7.3.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-2972?

2 open source packages ship an affected version, including @antfu/utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@antfu/utils` | npm | All versions | 0.7.3 |
| `@antfu/utils` | npm | All versions | 0.7.3 |

Products: Antfu Utils.

## How do I fix CVE-2023-2972?

Upgrade @antfu/utils to 0.7.3 or later.

## Is CVE-2023-2972 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2972 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2972 and fix it if it is affected.

What it is: CVE-2023-2972 is a medium-severity vulnerability in antfu/utils, published on 30 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2972 exists.

Affected packages and fixed versions:
- @antfu/utils (npm): affected all versions; fixed in 0.7.3
- @antfu/utils (npm): affected all versions; fixed in 0.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2972/ (Markdown: https://insights.sbomify.com/CVE-2023-2972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2972
- OSV: https://osv.dev/vulnerability/CVE-2023-2972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2972/
Summaries are generated and may contain mistakes; the official description above is the record.
