{"answers":{"affected":"2 open source packages ship an affected version, including io.quarkus:quarkus-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-2974 in the wild and no public exploit code.","fix":"Upgrade io.quarkus:quarkus-core to 2.16.8.Final or later.","what":"CVE-2023-2974 is a medium-severity vulnerability in Red Hat build of Quarkus 2.13.8.Final, published on 4 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-2974 and fix it if it is affected.\n\nWhat it is: CVE-2023-2974 is a medium-severity vulnerability in Red Hat build of Quarkus 2.13.8.Final, published on 4 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-2974 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.quarkus:quarkus-core (Maven): affected all versions; fixed in 2.16.8.Final\n- io.quarkus:quarkus-core (Maven): affected all versions; fixed in 2.16.8.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-2974/ (Markdown: https://insights.sbomify.com/CVE-2023-2974/index.md)","id":"CVE-2023-2974","markdown":"https://insights.sbomify.com/CVE-2023-2974/index.md","name":"CVE-2023-2974","record":{"aliases":["GHSA-3fhx-3vvg-2j84"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Quarkus Java framework","requires_auth":"high_privilege","summary":"Attackers can force weaker TLS protocols in Quarkus applications, bypassing configured security settings and potentially exposing data to downgrade attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"build_of_quarkus","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-757","name":"Selection of Less-Secure Algorithm During Negotiation"}],"description":"A vulnerability was found in quarkus-core. This vulnerability occurs because the TLS protocol configured with quarkus.http.ssl.protocols is not enforced, and the client can force the selection of the weaker supported TLS protocol.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"quarkus-core vulnerable to client driven TLS cipher downgrading","id":"CVE-2023-2974","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"AES-SIV implementation ignores empty associated data entries","id":"CVE-2023-2975"},"packages":[{"ecosystem":"Maven","fixed":["2.16.8.Final"],"introduced":["0"],"last_affected":[],"package":"io.quarkus:quarkus-core","purl":null,"source":"GHSA-3fhx-3vvg-2j84"},{"ecosystem":"Maven","fixed":["2.16.8.Final"],"introduced":["0"],"last_affected":[],"package":"io.quarkus:quarkus-core","purl":"pkg:maven/io.quarkus/quarkus-core","source":"GHSA-3fhx-3vvg-2j84"}],"prev":{"headline":"SourceCodester Students Online Internship Timesheet Syste cross site scripting","id":"CVE-2023-2973"},"products":["Red Hat build of Quarkus 2.13.8.Final"],"published":"2023-07-04","related":[{"cvss_score":7.5,"headline":"Undertow client not checking server identity presented by server certificate in https connections","id":"CVE-2022-4492","kev_date_added":null,"published":"2023-02-23"},{"cvss_score":6.5,"headline":"Keycloak Untrusted Certificate Validation vulnerability","id":"CVE-2023-1664","kev_date_added":null,"published":"2023-05-26"},{"cvss_score":6.1,"headline":"SmallRye Health UI Cross-site Scripting vulnerability","id":"CVE-2021-3914","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":5.3,"headline":"Quarkus: potential invalid reuse of context when @cacheresult on a uni is used","id":"CVE-2023-6393","kev_date_added":null,"published":"2023-12-06"},{"cvss_score":4.8,"headline":"Cross-site Scripting in Wildfly","id":"CVE-2021-3536","kev_date_added":null,"published":"2021-05-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Red Hat"]},"summary":"Attackers can force weaker TLS protocols in Quarkus applications, bypassing configured security settings and potentially exposing data to downgrade attacks.","url":"https://insights.sbomify.com/CVE-2023-2974/"}