# CVE-2023-2974: quarkus-core vulnerable to client driven TLS cipher downgrading

> Attackers can force weaker TLS protocols in Quarkus applications, bypassing configured security settings and potentially exposing data to downgrade attacks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jul 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-3fhx-3vvg-2j84

## What is CVE-2023-2974?

CVE-2023-2974 is a medium-severity vulnerability in Red Hat build of Quarkus 2.13.8.Final, published on 4 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability was found in quarkus-core. This vulnerability occurs because the TLS protocol configured with quarkus.http.ssl.protocols is not enforced, and the client can force the selection of the weaker supported TLS protocol.

Weakness: CWE-757 (Selection of Less-Secure Algorithm During Negotiation)

## Which versions are affected by CVE-2023-2974?

2 open source packages ship an affected version, including io.quarkus:quarkus-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkus:quarkus-core` | Maven | All versions | 2.16.8.Final |
| `io.quarkus:quarkus-core` | Maven | All versions | 2.16.8.Final |

Products: Redhat Build of Quarkus.

## How do I fix CVE-2023-2974?

Upgrade io.quarkus:quarkus-core to 2.16.8.Final or later.

## Is CVE-2023-2974 being exploited?

There is no known exploitation of CVE-2023-2974 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat build of Quarkus 2.13.8.Final

- [CVE-2022-4492](https://insights.sbomify.com/CVE-2022-4492/): Undertow client not checking server identity presented by server certificate in https connections (high 7.5)
- [CVE-2023-1664](https://insights.sbomify.com/CVE-2023-1664/): Keycloak Untrusted Certificate Validation vulnerability (medium 6.5)
- [CVE-2021-3914](https://insights.sbomify.com/CVE-2021-3914/): SmallRye Health UI Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2023-6393](https://insights.sbomify.com/CVE-2023-6393/): Quarkus: potential invalid reuse of context when @cacheresult on a uni is used (medium 5.3)
- [CVE-2021-3536](https://insights.sbomify.com/CVE-2021-3536/): Cross-site Scripting in Wildfly (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2974 and fix it if it is affected.

What it is: CVE-2023-2974 is a medium-severity vulnerability in Red Hat build of Quarkus 2.13.8.Final, published on 4 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-2974 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.quarkus:quarkus-core (Maven): affected all versions; fixed in 2.16.8.Final
- io.quarkus:quarkus-core (Maven): affected all versions; fixed in 2.16.8.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2974/ (Markdown: https://insights.sbomify.com/CVE-2023-2974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2974
- OSV: https://osv.dev/vulnerability/CVE-2023-2974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2974/
Summaries are generated and may contain mistakes; the official description above is the record.
