# CVE-2023-2982: WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn) <= 7.6.4 - Authentication Bypass

> Unauthenticated attackers can log in as any existing user, including administrators, by exploiting insufficient encryption in the social login plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jun 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-rx5f-42wm-7p9j

## What is CVE-2023-2982?

CVE-2023-2982 is a critical authentication bypass vulnerability in cyberlord92 miniOrange Social Login and Register (Discord, Google, Twitter, LinkedIn), published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn) plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 7.6.4. This is due to insufficient encryption on the user being supplied during a login validated through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they know the email address associated with that user. This was partially patched in version 7.6.4 and fully patched in version 7.6.5.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2023-2982?

It affects 1 product.


Products: Miniorange Wordpress Social Login and Register \(Discord\, Google\, Twitter\, Linkedin\).

## How do I fix CVE-2023-2982?

No fix has been published for CVE-2023-2982 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-2982 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2982 exists.

Public exploit code:

- WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn) <= 7.6.4 - Authentication Bypass (github_poc): https://github.com/RandomRobbieBF/CVE-2023-2982
- WordPress社交登录和注册（Discord，Google，Twitter，LinkedIn）<=7.6.4-绕过身份验证 (github_poc): https://github.com/H4K6/CVE-2023-2982-POC
- https://github.com/LoaiEsam37/CVE-2023-2982 (github_poc): https://github.com/LoaiEsam37/CVE-2023-2982
- https://github.com/wshinkle/CVE-2023-2982 (github_poc): https://github.com/wshinkle/CVE-2023-2982
- Miniorange Social Login and Register <= 7.6.3 - Authentication Bypass (nuclei): http/cves/2023/CVE-2023-2982.yaml

## Other vulnerabilities in cyberlord92 miniOrange Social Login and Register (Discord, Google, Twitter, LinkedIn)

- [CVE-2023-23710](https://insights.sbomify.com/CVE-2023-23710/): Cross-site scripting in WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn) (medium 5.9)
- [CVE-2023-23706](https://insights.sbomify.com/CVE-2023-23706/): Cross-site request forgery in WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2982 and fix it if it is affected.

What it is: CVE-2023-2982 is a critical authentication bypass vulnerability in cyberlord92 miniOrange Social Login and Register (Discord, Google, Twitter, LinkedIn), published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2982 exists.

Affected product: cyberlord92 miniOrange Social Login and Register (Discord, Google, Twitter, LinkedIn). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2982/ (Markdown: https://insights.sbomify.com/CVE-2023-2982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2982
- OSV: https://osv.dev/vulnerability/CVE-2023-2982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2982/
Summaries are generated and may contain mistakes; the official description above is the record.
