# CVE-2023-29824: Withdrawn: Use after free in SciPy

> A use-after-free flaw in SciPy's Py_FindObjects function was reported, though the vendor states it is not a security issue.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2023
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-29824, GHSA-jrfm-2h82-xg28, PYSEC-2023-114

## What is CVE-2023-29824?

CVE-2023-29824 is a critical use after free vulnerability in n/a, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A use-after-free issue was discovered in Py_FindObjects() function in SciPy versions prior to 1.8.0. NOTE: the vendor and discoverer indicate that this is not a security issue.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2023-29824?

3 open source packages ship an affected version, including scipy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scipy` | PyPI | All versions | 1.8.0 |
| `scipy` | PyPI | All versions | 1.8.0 |
| `scipy` | PyPI | All versions | 1.8.0 |

Products: Scipy Scipy.

## How do I fix CVE-2023-29824?

Upgrade scipy to 1.8.0 or later.

## Is CVE-2023-29824 being exploited?

There is no known exploitation of CVE-2023-29824 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-25399](https://insights.sbomify.com/CVE-2023-25399/): Withdrawn: scipy memory leak vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29824 and fix it if it is affected.

What it is: CVE-2023-29824 is a critical use after free vulnerability in n/a, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29824 in the wild and no public exploit code.

Affected packages and fixed versions:
- scipy (PyPI): affected all versions; fixed in 1.8.0
- scipy (PyPI): affected all versions; fixed in 1.8.0
- scipy (PyPI): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29824/ (Markdown: https://insights.sbomify.com/CVE-2023-29824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29824
- OSV: https://osv.dev/vulnerability/CVE-2023-29824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29824/
Summaries are generated and may contain mistakes; the official description above is the record.
