# CVE-2023-2983: Privilege Defined With Unsafe Actions in pimcore/pimcore

> Attackers can escalate privileges due to unsafe actions defined in privileges within the Pimcore CMS.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-m4mv-rmr7-h5f5

## What is CVE-2023-2983?

CVE-2023-2983 is a medium-severity vulnerability in Pimcore Pimcore, published on 30 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Privilege Defined With Unsafe Actions in GitHub repository pimcore/pimcore prior to 10.5.23.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions)

## Which versions are affected by CVE-2023-2983?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.23 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.23 |

Products: Pimcore Pimcore.

## How do I fix CVE-2023-2983?

Upgrade pimcore/pimcore to 10.5.23 or later.

## Is CVE-2023-2983 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2983 exists.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2983 and fix it if it is affected.

What it is: CVE-2023-2983 is a medium-severity vulnerability in Pimcore Pimcore, published on 30 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2983 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.23
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2983/ (Markdown: https://insights.sbomify.com/CVE-2023-2983/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2983
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2983
- OSV: https://osv.dev/vulnerability/CVE-2023-2983

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2983/
Summaries are generated and may contain mistakes; the official description above is the record.
