CVE-2023-29931 laravel-s vulnerable to Local File Inclusion

Critical 9.8 Published Updated

An attacker can exploit a Local File Inclusion vulnerability in the laravel-s library to read arbitrary files from the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-29931?

CVE-2023-29931 is a critical path traversal vulnerability in n/a, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

laravel-s 3.7.35 is vulnerable to Local File Inclusion via /src/Illuminate/Laravel.php.

Weakness: CWE-552

Which versions are affected by CVE-2023-29931?

2 open source packages ship an affected version, including hhxsv5/laravel-s. It affects 1 product.

PackageAffectedFixed in
hhxsv5/laravel-s PackagistAll versions3.7.36
hhxsv5/laravel-s PackagistAll versions3.7.36

Products include Laravels Project Laravels.

How do I fix CVE-2023-29931?

Upgrade hhxsv5/laravel-s to 3.7.36 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-29931 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29931 exists.

Sources

Also known as GHSA-q2fp-jw87-86px.

Is CVE-2023-29931 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free