# CVE-2023-29931: laravel-s vulnerable to Local File Inclusion

> An attacker can exploit a Local File Inclusion vulnerability in the laravel-s library to read arbitrary files from the server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2023
- **Updated:** 6 Dec 2024
- **Also known as:** GHSA-q2fp-jw87-86px

## What is CVE-2023-29931?

CVE-2023-29931 is a critical path traversal vulnerability in n/a, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

laravel-s 3.7.35 is vulnerable to Local File Inclusion via /src/Illuminate/Laravel.php.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2023-29931?

2 open source packages ship an affected version, including hhxsv5/laravel-s. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hhxsv5/laravel-s` | Packagist | All versions | 3.7.36 |
| `hhxsv5/laravel-s` | Packagist | All versions | 3.7.36 |

Products: Laravels Project Laravels.

## How do I fix CVE-2023-29931?

Upgrade hhxsv5/laravel-s to 3.7.36 or later.

## Is CVE-2023-29931 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29931 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29931 and fix it if it is affected.

What it is: CVE-2023-29931 is a critical path traversal vulnerability in n/a, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29931 exists.

Affected packages and fixed versions:
- hhxsv5/laravel-s (Packagist): affected all versions; fixed in 3.7.36
- hhxsv5/laravel-s (Packagist): affected all versions; fixed in 3.7.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29931/ (Markdown: https://insights.sbomify.com/CVE-2023-29931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29931
- OSV: https://osv.dev/vulnerability/CVE-2023-29931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29931/
Summaries are generated and may contain mistakes; the official description above is the record.
