# CVE-2023-30019: imgproxy is vulnerable to Server-Side Request Forgery

> Attackers can exploit unsanitized image URLs in imgproxy to perform Server-Side Request Forgery, potentially accessing internal resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-9x7h-ggc3-xg47, GO-2023-1761

## What is CVE-2023-30019?

CVE-2023-30019 is a medium-severity server-side request forgery vulnerability in n/a, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

imgproxy <=3.14.0 is vulnerable to Server-Side Request Forgery (SSRF) due to a lack of sanitization of the imageURL parameter.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-30019?

5 open source packages ship an affected version, including github.com/imgproxy/imgproxy/v3, github.com/imgproxy/imgproxy and github.com/imgproxy/imgproxy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.15.0 |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.15.0 |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.15.0 |
| `github.com/imgproxy/imgproxy` | Go | All versions | None |
| `github.com/imgproxy/imgproxy/v2` | Go | All versions | None |

Products: Evilmartians Imgproxy.

## How do I fix CVE-2023-30019?

Upgrade github.com/imgproxy/imgproxy/v3 to 3.15.0 or later.

## Is CVE-2023-30019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30019 exists.

Public exploit code:

- Imgproxy <= 3.14.0 - Server-side request forgery (SSRF) (nuclei): http/cves/2023/CVE-2023-30019.yaml

## Other vulnerabilities in n/a

- [CVE-2023-1496](https://insights.sbomify.com/CVE-2023-1496/): Cross-site Scripting (XSS) - Reflected in imgproxy/imgproxy (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30019 and fix it if it is affected.

What it is: CVE-2023-30019 is a medium-severity server-side request forgery vulnerability in n/a, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30019 exists.

Affected packages and fixed versions:
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.15.0
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.15.0
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.15.0
- github.com/imgproxy/imgproxy (Go): affected all versions; no fix listed
- github.com/imgproxy/imgproxy/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30019/ (Markdown: https://insights.sbomify.com/CVE-2023-30019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30019
- OSV: https://osv.dev/vulnerability/CVE-2023-30019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30019/
Summaries are generated and may contain mistakes; the official description above is the record.
