# CVE-2023-30094: Cross-site scripting in TotalJS

> Attackers can execute arbitrary scripts via stored XSS in the platform name field of TotalJS Flow settings.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2023
- **Updated:** 29 Jan 2025
- **Also known as:** GHSA-jj45-24rw-v6jw

## What is CVE-2023-30094?

CVE-2023-30094 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in TotalJS Flow v10 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the platform name field in the settings module.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-30094?

2 open source packages ship an affected version, including total4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `total4` | npm | All versions | 0.0.81 |
| `total4` | npm | All versions | 0.0.81 |

Products: Totaljs Flow.

## How do I fix CVE-2023-30094?

Upgrade total4 to 0.0.81 or later.

## Is CVE-2023-30094 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30094 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30094 and fix it if it is affected.

What it is: CVE-2023-30094 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30094 exists.

Affected packages and fixed versions:
- total4 (npm): affected all versions; fixed in 0.0.81
- total4 (npm): affected all versions; fixed in 0.0.81

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30094/ (Markdown: https://insights.sbomify.com/CVE-2023-30094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30094
- OSV: https://osv.dev/vulnerability/CVE-2023-30094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30094/
Summaries are generated and may contain mistakes; the official description above is the record.
