# CVE-2023-30145: Server-Side Template Injection in Camaleon CMS

> Attackers can execute arbitrary code via Server-Side Template Injection in Camaleon CMS, requiring immediate upgrade.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 16 Jan 2025
- **Also known as:** GHSA-x487-866m-p8hr

## What is CVE-2023-30145?

CVE-2023-30145 is a critical code injection vulnerability in n/a, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Camaleon CMS v2.7.0 was discovered to contain a Server-Side Template Injection (SSTI) vulnerability via the formats parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-30145?

2 open source packages ship an affected version, including camaleon_cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `camaleon_cms` | RubyGems | All versions | 2.7.4 |
| `camaleon_cms` | RubyGems | All versions | 2.7.4 |

Products: Tuzitio Camaleon Cms.

## How do I fix CVE-2023-30145?

Upgrade camaleon_cms to 2.7.4 or later.

## Is CVE-2023-30145 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30145 exists.

Public exploit code:

- Camaleon CMS v2.7.0 contain a Server-Side Template  Injection (SSTI) vulnerability  (github_poc): https://github.com/paragbagul111/CVE-2023-30145
- Camaleon CMS v2.7.0 - Server-Side Template Injection (SSTI) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2024-46986](https://insights.sbomify.com/CVE-2024-46986/): Arbitrary file write leading to RCE in Camaleon CMS (critical 10.0)
- [CVE-2021-25970](https://insights.sbomify.com/CVE-2021-25970/): Camaleon CMS - Insufficient Session Expiration after Password Change (high 8.8)
- [CVE-2024-46987](https://insights.sbomify.com/CVE-2024-46987/): Arbitrary path traversal in Camaleon CMS (high 7.7)
- [CVE-2021-25969](https://insights.sbomify.com/CVE-2021-25969/): Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments (medium 6.1)
- [CVE-2018-18260](https://insights.sbomify.com/CVE-2018-18260/): Camaleon CMS vulnerable to Stored Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30145 and fix it if it is affected.

What it is: CVE-2023-30145 is a critical code injection vulnerability in n/a, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30145 exists.

Affected packages and fixed versions:
- camaleon_cms (RubyGems): affected all versions; fixed in 2.7.4
- camaleon_cms (RubyGems): affected all versions; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30145/ (Markdown: https://insights.sbomify.com/CVE-2023-30145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30145
- OSV: https://osv.dev/vulnerability/CVE-2023-30145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30145/
Summaries are generated and may contain mistakes; the official description above is the record.
