CVE-2023-30177 Cross Site Scripting in CraftCMS

Medium 6.1 Published Updated

An attacker can inject JavaScript into the Volume Name field in CraftCMS, potentially executing arbitrary code in the context of other users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-30177?

CVE-2023-30177 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 25 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

CraftCMS 3.7.59 is vulnerable Cross Site Scripting (XSS). An attacker can inject javascript code into Volume Name.

Weakness: CWE-79

Which versions are affected by CVE-2023-30177?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.

PackageAffectedFixed in
craftcms/cms PackagistAll versions3.7.68
craftcms/cms PackagistAll versions3.7.68

Products include Craftcms Craft Cms.

How do I fix CVE-2023-30177?

Upgrade craftcms/cms to 3.7.68 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-30177 being exploited?

There is no known exploitation of CVE-2023-30177 in the wild and no public exploit code.

All Craftcms Craft Cms vulnerabilities

Sources

Also known as GHSA-wv7j-rc2q-9j67.

Is CVE-2023-30177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free