# CVE-2023-30253: Dolibarr vulnerable to remote code execution via uppercase manipulation

> Authenticated attackers can execute arbitrary code by bypassing PHP tag filters using uppercase manipulation in Dolibarr.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** BIT-dolibarr-2023-30253, GHSA-9wqr-5jp4-mjmh, UBUNTU-CVE-2023-30253

## What is CVE-2023-30253?

CVE-2023-30253 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 29 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-30253?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 17.0.1 |
| `dolibarr/dolibarr` | Packagist | All versions | 17.0.1 |
| `dolibarr` | Bitnami | All versions | 17.0.1 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2023-30253?

Upgrade dolibarr/dolibarr to 17.0.1 or later.

## Is CVE-2023-30253 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30253 exists.

Public exploit code:

- Reverse Shell POC exploit for Dolibarr <= 17.0.0 (CVE-2023-30253), PHP Code Injection (github_poc): https://github.com/nikn0laty/Exploit-for-Dolibarr-17.0.0-CVE-2023-30253
- In Dolibarr 17.0.0 with the CMS Website plugin (core) enabled, an authenticated attacker can obtain remote command execution via php code injection bypassing the application restrictions. (github_poc): https://github.com/dollarboysushil/Dolibarr-17.0.0-Exploit-CVE-2023-30253
- Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data. (github_poc): https://github.com/Rubikcuv5/cve-2023-30253
- I couldn’t find a PoC for CVE-2023-30253, so I developed an effective one (github_poc): https://github.com/g4nkd/CVE-2023-30253-PoC
- An authenticated RCE exploit for Dolibarr ERP/CRM CVE-2023-30253. (github_poc): https://github.com/andria-dev/DolibabyPhp
- Dolibarr ERP/CRM Authenticated Code Injection (metasploit)

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30253 and fix it if it is affected.

What it is: CVE-2023-30253 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 29 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30253 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 17.0.1
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 17.0.1
- dolibarr (Bitnami): affected all versions; fixed in 17.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30253/ (Markdown: https://insights.sbomify.com/CVE-2023-30253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30253
- OSV: https://osv.dev/vulnerability/CVE-2023-30253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30253/
Summaries are generated and may contain mistakes; the official description above is the record.
