CVE-2023-30428 Apache Pulsar Broker: Incorrect Authorization Validation for Rest Producer
Authenticated users can bypass authorization to produce messages to any topic, potentially affecting other tenants' data integrity and confidentiality.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-30428?
CVE-2023-30428 is a high-severity missing authorization vulnerability in Apache Pulsar Broker, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0.
The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability.
There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants.
2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected.
Weakness: CWE-863
Which versions are affected by CVE-2023-30428?
4 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar-broker Maven | From 2.11.0 | 2.11.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.11.0 | 2.11.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.10.4 |
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.10.4 |
Products include Apache Pulsar.
How do I fix CVE-2023-30428?
Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.11.1 or 2.10.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-30428 being exploited?
There is no known exploitation of CVE-2023-30428 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar Broker
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-j2r7-3rvw-g7gx.