# CVE-2023-30429: Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy

> Attackers can escalate privileges by exploiting incorrect authorization in Apache Pulsar Function Worker when using mTLS via Proxy.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-g9cv-v3v4-3h8r

## What is CVE-2023-30429?

CVE-2023-30429 is a critical missing authorization vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar.

This issue affects Apache Pulsar: before 2.10.4, and 2.11.0.

When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role.

The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version.

2.10 Pulsar Function Worker users should upgrade to at least 2.10.4.
2.11 Pulsar Function Worker users should upgrade to at least 2.11.1.
3.0 Pulsar Function Worker users are unaffected.
Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-30429?

4 open source packages ship an affected version, including org.apache.pulsar:pulsar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.10.4 |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.10.4 |
| `org.apache.pulsar:pulsar` | Maven | From 2.11.0 | 2.11.1 |
| `org.apache.pulsar:pulsar` | Maven | From 2.11.0 | 2.11.1 |

Products: Apache Pulsar.

## How do I fix CVE-2023-30429?

Upgrade org.apache.pulsar:pulsar to a fixed version for your release line: 2.10.4 or 2.11.1.

## Is CVE-2023-30429 being exploited?

There is no known exploitation of CVE-2023-30429 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)
- [CVE-2022-34321](https://insights.sbomify.com/CVE-2022-34321/): Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30429 and fix it if it is affected.

What it is: CVE-2023-30429 is a critical missing authorization vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30429 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.10.4
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.10.4
- org.apache.pulsar:pulsar (Maven): affected from 2.11.0; fixed in 2.11.1
- org.apache.pulsar:pulsar (Maven): affected from 2.11.0; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30429/ (Markdown: https://insights.sbomify.com/CVE-2023-30429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30429
- OSV: https://osv.dev/vulnerability/CVE-2023-30429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30429/
Summaries are generated and may contain mistakes; the official description above is the record.
