# CVE-2023-30535: Snowflake JDBC vulnerable to command injection via SSO URL authentication

> Attackers can achieve remote code execution on user machines by tricking them into visiting a malicious connection URL processed by the Snowflake JDBC driver.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-4g3j-c4wg-6j7x

## What is CVE-2023-30535?

CVE-2023-30535 is a high-severity command injection vulnerability in snowflakedb snowflake-jdbc, published on 14 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Snowflake JDBC provides a JDBC type 4 driver that supports core functionality, allowing Java program to connect to Snowflake. Users of the Snowflake JDBC driver were vulnerable to a command injection vulnerability. An attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. The vulnerability was patched on March 17, 2023 as part of Snowflake JDBC driver Version 3.13.29. All users should immediately upgrade the Snowflake JDBC driver to the latest version: 3.13.29.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-30535?

2 open source packages ship an affected version, including net.snowflake:snowflake-jdbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.snowflake:snowflake-jdbc` | Maven | All versions | 3.13.29 |
| `net.snowflake:snowflake-jdbc` | Maven | All versions | 3.13.29 |

Products: Snowflake Snowflake Jdbc.

## How do I fix CVE-2023-30535?

Upgrade net.snowflake:snowflake-jdbc to 3.13.29 or later.

## Is CVE-2023-30535 being exploited?

There is no known exploitation of CVE-2023-30535 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-jdbc

- [CVE-2025-24789](https://insights.sbomify.com/CVE-2025-24789/): Snowflake JDBC allows an untrusted search path on Windows (high 7.8)
- [CVE-2024-43382](https://insights.sbomify.com/CVE-2024-43382/): Snowflake JDBC Security Advisory (medium 5.9)
- [CVE-2026-3293](https://insights.sbomify.com/CVE-2026-3293/): snowflakedb snowflake-jdbc JDBC URL SdkProxyRoutePlanner.java SdkProxyRoutePlanner redos (medium 4.8)
- [CVE-2025-24790](https://insights.sbomify.com/CVE-2025-24790/): Snowflake JDBC uses insecure temporary credential cache file permissions (medium 4.4)
- [CVE-2025-27496](https://insights.sbomify.com/CVE-2025-27496/): Snowflake JDBC Driver client-side encryption key in DEBUG logs (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30535 and fix it if it is affected.

What it is: CVE-2023-30535 is a high-severity command injection vulnerability in snowflakedb snowflake-jdbc, published on 14 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30535 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.snowflake:snowflake-jdbc (Maven): affected all versions; fixed in 3.13.29
- net.snowflake:snowflake-jdbc (Maven): affected all versions; fixed in 3.13.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30535/ (Markdown: https://insights.sbomify.com/CVE-2023-30535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30535
- OSV: https://osv.dev/vulnerability/CVE-2023-30535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30535/
Summaries are generated and may contain mistakes; the official description above is the record.
