{"answers":{"affected":"6 open source packages ship an affected version, including slim/psr7. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30536 in the wild and no public exploit code.","fix":"Upgrade slim/psr7 to a fixed version for your release line: 1.4.1, 1.5.1 or 1.6.1.","what":"CVE-2023-30536 is a medium-severity vulnerability in slimphp Slim-Psr7, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30536 and fix it if it is affected.\n\nWhat it is: CVE-2023-30536 is a medium-severity vulnerability in slimphp Slim-Psr7, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30536 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- slim/psr7 (Packagist): affected all versions; fixed in 1.4.1\n- slim/psr7 (Packagist): affected all versions; fixed in 1.4.1\n- slim/psr7 (Packagist): affected from 1.5; fixed in 1.5.1\n- slim/psr7 (Packagist): affected from 1.5; fixed in 1.5.1\n- slim/psr7 (Packagist): affected from 1.6; fixed in 1.6.1\n- slim/psr7 (Packagist): affected from 1.6; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30536/ (Markdown: https://insights.sbomify.com/CVE-2023-30536/index.md)","id":"CVE-2023-30536","markdown":"https://insights.sbomify.com/CVE-2023-30536/index.md","name":"CVE-2023-30536","record":{"aliases":["DEBIAN-CVE-2023-30536","GHSA-q2qj-628g-vhfw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP PSR-7 library","requires_auth":"none","summary":"Attackers can inject newlines into headers causing malformed requests and potential denial of service via WAF bans.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"slim_psr-7","vendor":"slimframework"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\\n) into both the header names and values. While the specification states that \\r\\n\\r\\n is used to terminate the header list, many servers in the wild will also accept \\n\\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. The issue has been patched in version 1.6.1. There are no known workarounds to this issue. Users are advised to upgrade.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure header validation in slim/psr7","id":"CVE-2023-30536","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2023"},"n_packages":6,"n_references":3,"next":{"headline":"org.xwiki.platform:xwiki-platform-flamingo-theme-ui vulnerable to privilege escalation","id":"CVE-2023-30537"},"packages":[{"ecosystem":"Packagist","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"slim/psr7","purl":null,"source":"GHSA-q2qj-628g-vhfw"},{"ecosystem":"Packagist","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"slim/psr7","purl":"pkg:composer/slim/psr7","source":"GHSA-q2qj-628g-vhfw"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["1.5"],"last_affected":[],"package":"slim/psr7","purl":null,"source":"GHSA-q2qj-628g-vhfw"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["1.5"],"last_affected":[],"package":"slim/psr7","purl":"pkg:composer/slim/psr7","source":"GHSA-q2qj-628g-vhfw"},{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["1.6"],"last_affected":[],"package":"slim/psr7","purl":null,"source":"GHSA-q2qj-628g-vhfw"},{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["1.6"],"last_affected":[],"package":"slim/psr7","purl":"pkg:composer/slim/psr7","source":"GHSA-q2qj-628g-vhfw"}],"prev":{"headline":"Snowflake JDBC vulnerable to command injection via SSO URL authentication","id":"CVE-2023-30535"},"products":["Slim-Psr7"],"published":"2023-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-05","vendors":["slimphp"]},"summary":"Attackers can inject newlines into headers causing malformed requests and potential denial of service via WAF bans.","url":"https://insights.sbomify.com/CVE-2023-30536/"}