CVE-2023-30541 TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts

Medium 5.3 Published Updated

Attackers can cause denial of service in OpenZeppelin proxy contracts by exploiting selector clashes that prevent function delegation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-30541?

CVE-2023-30541 is a medium-severity denial of service vulnerability in openzeppelin-contracts, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.

Weakness: CWE-436

Which versions are affected by CVE-2023-30541?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.

PackageAffectedFixed in
@openzeppelin/contracts npmFrom 3.2.04.8.3
@openzeppelin/contracts npmFrom 3.2.04.8.3
@openzeppelin/contracts-upgradeable npmFrom 3.2.04.8.3
@openzeppelin/contracts-upgradeable npmFrom 3.2.04.8.3

Products include Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

How do I fix CVE-2023-30541?

Upgrade @openzeppelin/contracts to 4.8.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-30541 being exploited?

There is no known exploitation of CVE-2023-30541 in the wild and no public exploit code.

Sources

Also known as GHSA-mx2q-35m2-x2rh.

Is CVE-2023-30541 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free