# CVE-2023-30541: TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts

> Attackers can cause denial of service in OpenZeppelin proxy contracts by exploiting selector clashes that prevent function delegation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-mx2q-35m2-x2rh

## What is CVE-2023-30541?

CVE-2023-30541 is a medium-severity denial of service vulnerability in openzeppelin-contracts, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2023-30541?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 3.2.0 | 4.8.3 |
| `@openzeppelin/contracts` | npm | From 3.2.0 | 4.8.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 3.2.0 | 4.8.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 3.2.0 | 4.8.3 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-30541?

Upgrade @openzeppelin/contracts to 4.8.3 or later.

## Is CVE-2023-30541 being exploited?

There is no known exploitation of CVE-2023-30541 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30541 and fix it if it is affected.

What it is: CVE-2023-30541 is a medium-severity denial of service vulnerability in openzeppelin-contracts, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30541 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 3.2.0; fixed in 4.8.3
- @openzeppelin/contracts (npm): affected from 3.2.0; fixed in 4.8.3
- @openzeppelin/contracts-upgradeable (npm): affected from 3.2.0; fixed in 4.8.3
- @openzeppelin/contracts-upgradeable (npm): affected from 3.2.0; fixed in 4.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30541/ (Markdown: https://insights.sbomify.com/CVE-2023-30541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30541
- OSV: https://osv.dev/vulnerability/CVE-2023-30541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30541/
Summaries are generated and may contain mistakes; the official description above is the record.
