# CVE-2023-30542: GovernorCompatibilityBravo may trim proposal calldata

> Attackers can create governance proposals with mismatched array lengths, causing actions to execute without intended calldata, potentially altering contract state unexpectedly.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-93hq-5wgc-jc82

## What is CVE-2023-30542?

CVE-2023-30542 is a medium-severity vulnerability in openzeppelin-contracts, published on 16 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. The proposal creation entrypoint (`propose`) in `GovernorCompatibilityBravo` allows the creation of proposals with a `signatures` array shorter than the `calldatas` array. This causes the additional elements of the latter to be ignored, and if the proposal succeeds the corresponding actions would eventually execute without any calldata. The `ProposalCreated` event correctly represents what will eventually execute, but the proposal parameters as queried through `getActions` appear to respect the original intended calldata. This issue has been patched in 4.8.3. As a workaround, ensure that all proposals that pass through governance have equal length `signatures` and `calldatas` parameters.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-30542?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.8.3 |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.8.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.8.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.8.3 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-30542?

Upgrade @openzeppelin/contracts to 4.8.3 or later.

## Is CVE-2023-30542 being exploited?

There is no known exploitation of CVE-2023-30542 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30542 and fix it if it is affected.

What it is: CVE-2023-30542 is a medium-severity vulnerability in openzeppelin-contracts, published on 16 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30542 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.8.3
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.8.3
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.8.3
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30542/ (Markdown: https://insights.sbomify.com/CVE-2023-30542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30542
- OSV: https://osv.dev/vulnerability/CVE-2023-30542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30542/
Summaries are generated and may contain mistakes; the official description above is the record.
