CVE-2023-30545 PrestaShop arbitrary file read vulnerability
Authenticated users with SQL Manager access can read arbitrary files via SQL injection, exposing critical system information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-30545?
CVE-2023-30545 is a high-severity SQL injection vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, it is possible for a user with access to the SQL Manager (Advanced Options -> Database) to arbitrarily read any file on the operating system when using SQL function `LOAD_FILE` in a `SELECT` request. This gives the user access to critical information. A patch is available in PrestaShop 8.0.4 and PS 1.7.8.9
Weakness: CWE-89
Which versions are affected by CVE-2023-30545?
4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
Products include Prestashop Prestashop.
How do I fix CVE-2023-30545?
Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.9 or 8.0.4.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2023-30545 being exploited?
There is no known exploitation of CVE-2023-30545 in the wild and no public exploit code.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-8r4m-5p6p-52rp.