# CVE-2023-30547: Sandbox Escape in vm2

> Attackers can escape the vm2 sandbox and execute arbitrary code on the host system by exploiting an exception sanitization flaw.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-ch3r-j5x3-6q2m, ROOT-APP-NPM-CVE-2023-30547

## What is CVE-2023-30547?

CVE-2023-30547 is a critical code injection vulnerability in patriksimek vm2, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. There exists a vulnerability in exception sanitization of vm2 for versions up to 3.9.16, allowing attackers to raise an unsanitized host exception inside `handleException()` which can be used to escape the sandbox and run arbitrary code in host context. This vulnerability was patched in the release of version `3.9.17` of `vm2`. There are no known workarounds for this vulnerability. Users are advised to upgrade.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-30547?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.9.17 |
| `vm2` | npm | All versions | 3.9.17 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2023-30547?

Upgrade vm2 to 3.9.17 or later.

## Is CVE-2023-30547 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30547 exists.

Public exploit code:

- PoC Exploit  for VM2 Sandbox Escape Vulnerability (github_poc): https://github.com/rvzsec/CVE-2023-30547
- Tool for exploring CVE-2023-30547 (github_poc): https://github.com/Cur1iosity/CVE-2023-30547
- PoC to CVE-2023-30547 (Library vm2) (github_poc): https://github.com/user0x1337/CVE-2023-30547
- https://github.com/junnythemarksman/CVE-2023-30547 (github_poc): https://github.com/junnythemarksman/CVE-2023-30547
-  Walkthrough for Codify (Linux - Easy). Exploits vm2 RCE (CVE-2023-30547), SQLite DB hash extraction, Bcrypt cracking with John, and Privilege Escalation via Bash wildcard comparison in `mysql-backup.sh`. (github_poc): https://github.com/R3fr4kt/Codify-TJNULL-OSCP-

## Other vulnerabilities in patriksimek vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2023-29017](https://insights.sbomify.com/CVE-2023-29017/): vm2 Sandbox Escape vulnerability (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30547 and fix it if it is affected.

What it is: CVE-2023-30547 is a critical code injection vulnerability in patriksimek vm2, published on 17 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30547 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.9.17
- vm2 (npm): affected all versions; fixed in 3.9.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30547/ (Markdown: https://insights.sbomify.com/CVE-2023-30547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30547
- OSV: https://osv.dev/vulnerability/CVE-2023-30547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30547/
Summaries are generated and may contain mistakes; the official description above is the record.
