CVE-2023-30548 Path traversal vulnerability in gatsby-plugin-sharp

Medium 4.3 Published Updated

Attackers can read arbitrary files if the Gatsby develop server is exposed to untrusted networks due to a path traversal flaw in the image processing plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-30548?

CVE-2023-30548 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server (`gatsby develop`). It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBY_HOST=0.0.0.0 environment variable. Attackers exploiting this vulnerability will have read access to all files within the scope of the server process. A patch has been introduced in [email protected] and [email protected] which mitigates the issue by ensuring that included paths remain within the project directory. As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability. Users are non the less encouraged to upgrade to a safe version.

Weakness: CWE-22

Which versions are affected by CVE-2023-30548?

4 open source packages ship an affected version, including gatsby-plugin-sharp. It affects 1 product.

PackageAffectedFixed in
gatsby-plugin-sharp npmAll versions4.25.1
gatsby-plugin-sharp npmAll versions4.25.1
gatsby-plugin-sharp npmFrom 5.0.05.8.1
gatsby-plugin-sharp npmFrom 5.0.05.8.1

Products include Gatsbyjs Gatsby-Plugin-Sharp.

How do I fix CVE-2023-30548?

Upgrade gatsby-plugin-sharp to a fixed version for your release line: 4.25.1 or 5.8.1.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-30548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30548 exists.

Sources

Also known as CLSA-2026-1792938613, GHSA-h2pm-378c-pcxx.

Is CVE-2023-30548 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free