# CVE-2023-30548: Path traversal vulnerability in gatsby-plugin-sharp

> Attackers can read arbitrary files if the Gatsby develop server is exposed to untrusted networks due to a path traversal flaw in the image processing plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** CLSA-2026-1792938613, GHSA-h2pm-378c-pcxx

## What is CVE-2023-30548?

CVE-2023-30548 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server (`gatsby develop`). It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBY_HOST=0.0.0.0 environment variable. Attackers exploiting this vulnerability will have read access to all files within the scope of the server process. A patch has been introduced in gatsby-plugin-sharp@5.8.1 and gatsby-plugin-sharp@4.25.1 which mitigates the issue by ensuring that included paths remain within the project directory. As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability. Users are non the less encouraged to upgrade to a safe version.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-30548?

4 open source packages ship an affected version, including gatsby-plugin-sharp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gatsby-plugin-sharp` | npm | All versions | 4.25.1 |
| `gatsby-plugin-sharp` | npm | All versions | 4.25.1 |
| `gatsby-plugin-sharp` | npm | From 5.0.0 | 5.8.1 |
| `gatsby-plugin-sharp` | npm | From 5.0.0 | 5.8.1 |

Products: Gatsbyjs Gatsby-Plugin-Sharp.

## How do I fix CVE-2023-30548?

Upgrade gatsby-plugin-sharp to a fixed version for your release line: 4.25.1 or 5.8.1.

## Is CVE-2023-30548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30548 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30548 and fix it if it is affected.

What it is: CVE-2023-30548 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30548 exists.

Affected packages and fixed versions:
- gatsby-plugin-sharp (npm): affected all versions; fixed in 4.25.1
- gatsby-plugin-sharp (npm): affected all versions; fixed in 4.25.1
- gatsby-plugin-sharp (npm): affected from 5.0.0; fixed in 5.8.1
- gatsby-plugin-sharp (npm): affected from 5.0.0; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30548/ (Markdown: https://insights.sbomify.com/CVE-2023-30548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30548
- OSV: https://osv.dev/vulnerability/CVE-2023-30548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30548/
Summaries are generated and may contain mistakes; the official description above is the record.
