CVE-2023-30549 Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer

High 7.1 Published Updated

Attackers can exploit a kernel use-after-free flaw via Apptainer's setuid mode to achieve privilege escalation or denial of service on unpatched systems.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-30549?

CVE-2023-30549 is a high-severity use after free vulnerability in Redhat Enterprise Linux, published on 25 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Apptainer is an open source container platform for Linux. There is an ext4 use-after-free flaw that is exploitable through versions of Apptainer < 1.1.0 and installations that include apptainer-suid < 1.1.8 on older operating systems where that CVE has not been patched. That includes Red Hat Enterprise Linux 7, Debian 10 buster (unless the linux-5.10 package is installed), Ubuntu 18.04 bionic and Ubuntu 20.04 focal. Use-after-free flaws in the kernel can be used to attack the kernel for denial of service and potentially for privilege escalation.

Apptainer 1.1.8 includes a patch that by default disables mounting of extfs filesystem types in setuid-root mode, while continuing to allow mounting of extfs filesystems in non-setuid "rootless" mode using fuse2fs.

Some workarounds are possible. Either do not install apptainer-suid (for versions 1.1.0 through 1.1.7) or set `allow setuid = no` in apptainer.conf. This requires having unprivileged user namespaces enabled and except for apptainer 1.1.x versions will disallow mounting of sif files, extfs files, and squashfs files in addition to other, less significant impacts. (Encrypted sif files are also not supported unprivileged in apptainer 1.1.x.). Alternatively, use the `limit containers` options in apptainer.conf/singularity.conf to limit sif files to trusted users, groups, and/or paths, and set `allow container extfs = no` to disallow mounting of extfs overlay files. The latter option by itself does not disallow mounting of extfs overlay partitions inside SIF files, so that's why the former options are also needed.

Weakness: CWE-416

Which versions are affected by CVE-2023-30549?

3 open source packages ship an affected version, including github.com/apptainer/apptainer. It affects 3 products.

PackageAffectedFixed in
github.com/apptainer/apptainer GoAll versions1.1.8
github.com/apptainer/apptainer GoAll versions1.1.8
github.com/apptainer/apptainer GoAll versions1.1.8
Linux distribution packages (1)
apptainer openSUSE:TumbleweedAll versions1.1.8-1.1

Products include Lfprojects Apptainer, Redhat Enterprise Linux, Sylabs Singularity.

How do I fix CVE-2023-30549?

Upgrade github.com/apptainer/apptainer to 1.1.8 or later.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2023-30549 being exploited?

There is no known exploitation of CVE-2023-30549 in the wild and no public exploit code.

All Redhat Enterprise Linux vulnerabilities

Sources

Also known as CLEANSTART-2024-PY02078, GHSA-j4rf-7357-f4cg, GO-2023-1738, UBUNTU-CVE-2023-30549, openSUSE-SU-2024:12894-1.

Is CVE-2023-30549 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free