{"answers":{"affected":"3 open source packages ship an affected version, including github.com/apptainer/apptainer. It affects 3 products.","exploited":"There is no known exploitation of CVE-2023-30549 in the wild and no public exploit code.","fix":"Upgrade github.com/apptainer/apptainer to 1.1.8 or later.","what":"CVE-2023-30549 is a high-severity use after free vulnerability in Redhat Enterprise Linux, published on 25 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30549 and fix it if it is affected.\n\nWhat it is: CVE-2023-30549 is a high-severity use after free vulnerability in Redhat Enterprise Linux, published on 25 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30549 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30549/ (Markdown: https://insights.sbomify.com/CVE-2023-30549/index.md)","id":"CVE-2023-30549","markdown":"https://insights.sbomify.com/CVE-2023-30549/index.md","name":"CVE-2023-30549","record":{"aliases":["CLEANSTART-2024-PY02078","GHSA-j4rf-7357-f4cg","GO-2023-1738","UBUNTU-CVE-2023-30549","openSUSE-SU-2024:12894-1"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"patch","impacts":["privilege_escalation","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Apptainer container platform","requires_auth":"none","summary":"Attackers can exploit a kernel use-after-free flaw via Apptainer's setuid mode to achieve privilege escalation or denial of service on unpatched systems.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apptainer","vendor":"lfprojects"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"singularity","vendor":"sylabs"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Apptainer is an open source container platform for Linux. There is an ext4 use-after-free flaw that is exploitable through versions of Apptainer \u003c 1.1.0 and installations that include apptainer-suid \u003c 1.1.8 on older operating systems where that CVE has not been patched. That includes Red Hat Enterprise Linux 7, Debian 10 buster (unless the linux-5.10 package is installed), Ubuntu 18.04 bionic and Ubuntu 20.04 focal. Use-after-free flaws in the kernel can be used to attack the kernel for denial of service and potentially for privilege escalation.\n\nApptainer 1.1.8 includes a patch that by default disables mounting of extfs filesystem types in setuid-root mode, while continuing to allow mounting of extfs filesystems in non-setuid \"rootless\" mode using fuse2fs.\n\nSome workarounds are possible. Either do not install apptainer-suid (for versions 1.1.0 through 1.1.7) or set `allow setuid = no` in apptainer.conf.  This requires having unprivileged user namespaces enabled and except for apptainer 1.1.x versions will disallow mounting of sif files, extfs files, and squashfs files in addition to other, less significant impacts.  (Encrypted sif files are also not supported unprivileged in apptainer 1.1.x.). Alternatively, use the `limit containers` options in apptainer.conf/singularity.conf to limit sif files to trusted users, groups, and/or paths, and set `allow container extfs = no` to disallow mounting of extfs overlay files.  The latter option by itself does not disallow mounting of extfs overlay partitions inside SIF files, so that's why the former options are also needed.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer","id":"CVE-2023-30549","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"redhat:enterprise_linux","products":["redhat:enterprise_linux"],"type":"use_after_free","year":"2023"},"n_packages":4,"n_references":13,"next":{"headline":"IDOR vulnerability exists in metersphere","id":"CVE-2023-30550"},"packages":[{"ecosystem":"Go","fixed":["1.1.8"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":null,"source":"GHSA-j4rf-7357-f4cg"},{"ecosystem":"Go","fixed":["1.1.8"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":"pkg:golang/github.com/apptainer/apptainer","source":"GHSA-j4rf-7357-f4cg"},{"ecosystem":"Go","fixed":["1.1.8"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":"pkg:golang/github.com/apptainer/apptainer","source":"GO-2023-1738"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.1.8-1.1"],"introduced":["0"],"last_affected":[],"package":"apptainer","purl":"pkg:rpm/opensuse/apptainer\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12894-1"}],"prev":{"headline":"Path traversal vulnerability in gatsby-plugin-sharp","id":"CVE-2023-30548"},"products":["apptainer"],"published":"2023-04-25","related":[{"cvss_score":6.1,"headline":"Apptainer's ineffective privileges drop when requesting container network","id":"CVE-2023-38496","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":4.5,"headline":"Apptainer ineffective application of selinux and apparmor --security options","id":"CVE-2025-65105","kev_date_added":null,"published":"2025-12-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["apptainer"]},"summary":"Attackers can exploit a kernel use-after-free flaw via Apptainer's setuid mode to achieve privilege escalation or denial of service on unpatched systems.","url":"https://insights.sbomify.com/CVE-2023-30549/"}