# CVE-2023-30549: Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer

> Attackers can exploit a kernel use-after-free flaw via Apptainer's setuid mode to achieve privilege escalation or denial of service on unpatched systems.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 5 Mar 2025
- **Also known as:** CLEANSTART-2024-PY02078, GHSA-j4rf-7357-f4cg, GO-2023-1738, UBUNTU-CVE-2023-30549, openSUSE-SU-2024:12894-1

## What is CVE-2023-30549?

CVE-2023-30549 is a high-severity use after free vulnerability in Redhat Enterprise Linux, published on 25 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apptainer is an open source container platform for Linux. There is an ext4 use-after-free flaw that is exploitable through versions of Apptainer < 1.1.0 and installations that include apptainer-suid < 1.1.8 on older operating systems where that CVE has not been patched. That includes Red Hat Enterprise Linux 7, Debian 10 buster (unless the linux-5.10 package is installed), Ubuntu 18.04 bionic and Ubuntu 20.04 focal. Use-after-free flaws in the kernel can be used to attack the kernel for denial of service and potentially for privilege escalation.

Apptainer 1.1.8 includes a patch that by default disables mounting of extfs filesystem types in setuid-root mode, while continuing to allow mounting of extfs filesystems in non-setuid "rootless" mode using fuse2fs.

Some workarounds are possible. Either do not install apptainer-suid (for versions 1.1.0 through 1.1.7) or set `allow setuid = no` in apptainer.conf.  This requires having unprivileged user namespaces enabled and except for apptainer 1.1.x versions will disallow mounting of sif files, extfs files, and squashfs files in addition to other, less significant impacts.  (Encrypted sif files are also not supported unprivileged in apptainer 1.1.x.). Alternatively, use the `limit containers` options in apptainer.conf/singularity.conf to limit sif files to trusted users, groups, and/or paths, and set `allow container extfs = no` to disallow mounting of extfs overlay files.  The latter option by itself does not disallow mounting of extfs overlay partitions inside SIF files, so that's why the former options are also needed.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2023-30549?

3 open source packages ship an affected version, including github.com/apptainer/apptainer. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apptainer/apptainer` | Go | All versions | 1.1.8 |
| `github.com/apptainer/apptainer` | Go | All versions | 1.1.8 |
| `github.com/apptainer/apptainer` | Go | All versions | 1.1.8 |
| `apptainer` | openSUSE:Tumbleweed | All versions | 1.1.8-1.1 |

Products: Lfprojects Apptainer, Redhat Enterprise Linux, Sylabs Singularity.

## How do I fix CVE-2023-30549?

Upgrade github.com/apptainer/apptainer to 1.1.8 or later.

## Is CVE-2023-30549 being exploited?

There is no known exploitation of CVE-2023-30549 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2023-38496](https://insights.sbomify.com/CVE-2023-38496/): Apptainer's ineffective privileges drop when requesting container network (medium 6.1)
- [CVE-2025-65105](https://insights.sbomify.com/CVE-2025-65105/): Apptainer ineffective application of selinux and apparmor --security options (medium 4.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30549 and fix it if it is affected.

What it is: CVE-2023-30549 is a high-severity use after free vulnerability in Redhat Enterprise Linux, published on 25 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30549 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30549/ (Markdown: https://insights.sbomify.com/CVE-2023-30549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30549
- OSV: https://osv.dev/vulnerability/CVE-2023-30549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30549/
Summaries are generated and may contain mistakes; the official description above is the record.
