# CVE-2023-30575: Apache Guacamole: Incorrect calculation of Guacamole protocol element lengths

> Attackers can inject malicious instructions during the handshake due to incorrect length calculations, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 10 Oct 2024
- **Also known as:** BIT-guacamole-2023-30575, BIT-guacamole-server-2023-30575, GHSA-jcgp-rv79-q77m, UBUNTU-CVE-2023-30575

## What is CVE-2023-30575?

CVE-2023-30575 is a medium-severity code injection vulnerability in Apache Guacamole, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Guacamole 1.5.1 and older may incorrectly calculate the lengths of instruction elements sent during the Guacamole protocol handshake, potentially allowing an attacker to inject Guacamole instructions during the handshake through specially-crafted data.

Weakness: CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2023-30575?

2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guacamole` | Bitnami | All versions | 1.5.2 |
| `guacamole-server` | Bitnami | All versions | 1.5.2 |

Products: Apache Guacamole.

## How do I fix CVE-2023-30575?

Upgrade guacamole to 1.5.2 or later.

## Is CVE-2023-30575 being exploited?

There is no known exploitation of CVE-2023-30575 in the wild and no public exploit code.

## Other vulnerabilities in Apache Guacamole

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2017-3158](https://insights.sbomify.com/CVE-2017-3158/): Apache Guacamole Race Condition vulnerability (high 8.1)
- [CVE-2023-43826](https://insights.sbomify.com/CVE-2023-43826/): Apache Guacamole: Integer overflow in handling of VNC image buffers (high 7.5)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2018-1340](https://insights.sbomify.com/CVE-2018-1340/): Missing Encryption of Sensitive Data in Apache Guacamole (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30575 and fix it if it is affected.

What it is: CVE-2023-30575 is a medium-severity code injection vulnerability in Apache Guacamole, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30575 in the wild and no public exploit code.

Affected packages and fixed versions:
- guacamole (Bitnami): affected all versions; fixed in 1.5.2
- guacamole-server (Bitnami): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30575/ (Markdown: https://insights.sbomify.com/CVE-2023-30575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30575
- OSV: https://osv.dev/vulnerability/CVE-2023-30575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30575/
Summaries are generated and may contain mistakes; the official description above is the record.
