{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30577 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-30577 is a high-severity command injection vulnerability in n/a, published on 26 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30577 and fix it if it is affected.\n\nWhat it is: CVE-2023-30577 is a high-severity command injection vulnerability in n/a, published on 26 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30577 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30577/ (Markdown: https://insights.sbomify.com/CVE-2023-30577/index.md)","id":"CVE-2023-30577","markdown":"https://insights.sbomify.com/CVE-2023-30577/index.md","name":"CVE-2023-30577","record":{"aliases":["CLSA-2023-1692296244","DEBIAN-CVE-2023-30577","GHSA-crrw-v393-h5q3","OESA-2023-1507","UBUNTU-CVE-2023-30577","USN-6614-1","openSUSE-SU-2023:0205-1","openSUSE-SU-2023:0206-1","openSUSE-SU-2024:13083-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AMANDA backup software","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via improper argument handling in AMANDA's runtar.c component.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"amanda","vendor":"zmanda"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"AMANDA (Advanced Maryland Automatic Network Disk Archiver) before tag-community-3.5.4 mishandles argument checking for runtar.c, a different vulnerability than CVE-2022-37705.","ecosystems":["SUSE:Package Hub 15 SP4","SUSE:Package Hub 15 SP5","openSUSE:Leap 15.4","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2023-30577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":5,"n_references":5,"next":{"headline":"Security feature bypass in Node","id":"CVE-2023-30581"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["3.5.1-bp154.3.6.1"],"introduced":["0"],"last_affected":[],"package":"amanda","purl":"pkg:rpm/suse/amanda\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2023:0206-1"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["3.5.2-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"amanda","purl":"pkg:rpm/suse/amanda\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2023:0205-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.5.1-bp154.3.6.1"],"introduced":["0"],"last_affected":[],"package":"amanda","purl":"pkg:rpm/opensuse/amanda\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2023:0206-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["3.5.2-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"amanda","purl":"pkg:rpm/opensuse/amanda\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2023:0205-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.5.4-1.1"],"introduced":["0"],"last_affected":[],"package":"amanda","purl":"pkg:rpm/opensuse/amanda\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13083-1"}],"prev":{"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576"},"products":["n/a"],"published":"2023-07-26","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-19469","kev_date_added":null,"published":"2019-12-01"},{"cvss_score":6.7,"headline":"Command injection in n/a","id":"CVE-2022-37704","kev_date_added":null,"published":"2023-04-16"},{"cvss_score":6.7,"headline":"Privilege escalation in n/a","id":"CVE-2022-37705","kev_date_added":null,"published":"2023-04-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via improper argument handling in AMANDA's runtar.c component.","url":"https://insights.sbomify.com/CVE-2023-30577/"}