# CVE-2023-30582: Missing authorization in Node

> Attackers can monitor unauthorized files via fs.watchFile when using the experimental permission model with specific flags.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2024
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-node-2023-30582, BIT-node-min-2023-30582, GHSA-cwrj-j635-2m7w

## What is CVE-2023-30582?

CVE-2023-30582 is a medium-severity missing authorization vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been identified in Node.js version 20, affecting users of the experimental permission model when the --allow-fs-read flag is used with a non-* argument. This flaw arises from an inadequate permission model that fails to restrict file watching through the fs.watchFile API. As a result, malicious actors can monitor files that they do not have explicit read access to.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-30582?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.3.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.3.1 |

## How do I fix CVE-2023-30582?

Upgrade node to 20.3.1 or later.

## Is CVE-2023-30582 being exploited?

There is no known exploitation of CVE-2023-30582 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30582 and fix it if it is affected.

What it is: CVE-2023-30582 is a medium-severity missing authorization vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30582 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.3.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30582/ (Markdown: https://insights.sbomify.com/CVE-2023-30582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30582
- OSV: https://osv.dev/vulnerability/CVE-2023-30582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30582/
Summaries are generated and may contain mistakes; the official description above is the record.
