# CVE-2023-30584: Path traversal in Node

> Attackers can bypass file permission checks in Node.js experimental permission model to access restricted files.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2024
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-node-2023-30584, BIT-node-min-2023-30584, GHSA-jpgc-8hrm-hvwj

## What is CVE-2023-30584?

CVE-2023-30584 is a high-severity path traversal vulnerability in NodeJS Node, published on 7 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been discovered in Node.js version 20, specifically within the experimental permission model. This flaw relates to improper handling of path traversal bypass when verifying file permissions.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-30584?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.3.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.3.1 |

## How do I fix CVE-2023-30584?

Upgrade node to 20.3.1 or later.

## Is CVE-2023-30584 being exploited?

There is no known exploitation of CVE-2023-30584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30584 and fix it if it is affected.

What it is: CVE-2023-30584 is a high-severity path traversal vulnerability in NodeJS Node, published on 7 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30584 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.3.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30584/ (Markdown: https://insights.sbomify.com/CVE-2023-30584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30584
- OSV: https://osv.dev/vulnerability/CVE-2023-30584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30584/
Summaries are generated and may contain mistakes; the official description above is the record.
