# CVE-2023-30586: Privilege escalation in Node

> Attackers can bypass Node.js experimental permission model via OpenSSL engines to escalate privileges and disable security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 8 May 2025
- **Also known as:** BIT-node-2023-30586, BIT-node-min-2023-30586, GHSA-jvqw-9mq6-23h9

## What is CVE-2023-30586?

CVE-2023-30586 is a high-severity vulnerability in Nodejs Node.js, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A privilege escalation vulnerability exists in Node.js 20 that allowed loading arbitrary OpenSSL engines when the experimental permission model is enabled, which can bypass and/or disable the permission model. The attack complexity is high. However, the crypto.setEngine() API can be used to bypass the permission model when called with a compatible OpenSSL engine. The OpenSSL engine can, for example, disable the permission model in the host process by manipulating the process's stack memory to locate the permission model Permission::enabled_ in the host process's heap memory. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-30586?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.3.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.3.1 |

Products: Nodejs Node.js.

## How do I fix CVE-2023-30586?

Upgrade node to 20.3.1 or later.

## Is CVE-2023-30586 being exploited?

There is no known exploitation of CVE-2023-30586 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30586 and fix it if it is affected.

What it is: CVE-2023-30586 is a high-severity vulnerability in Nodejs Node.js, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30586 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.3.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30586/ (Markdown: https://insights.sbomify.com/CVE-2023-30586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30586
- OSV: https://osv.dev/vulnerability/CVE-2023-30586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30586/
Summaries are generated and may contain mistakes; the official description above is the record.
