{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min.","exploited":"There is no known exploitation of CVE-2023-30587 in the wild and no public exploit code.","fix":"Upgrade node to 20.3.1 or later.","what":"CVE-2023-30587 is a high-severity vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30587 and fix it if it is affected.\n\nWhat it is: CVE-2023-30587 is a high-severity vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30587 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 20.0.0; fixed in 20.3.1\n- node-min (Bitnami): affected from 20.0.0; fixed in 20.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30587/ (Markdown: https://insights.sbomify.com/CVE-2023-30587/index.md)","id":"CVE-2023-30587","markdown":"https://insights.sbomify.com/CVE-2023-30587/index.md","name":"CVE-2023-30587","record":{"aliases":["BIT-node-2023-30587","BIT-node-min-2023-30587","GHSA-c595-v5xp-gv8w"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can bypass Node.js experimental permission restrictions via the inspector module, affecting users who enable this experimental feature.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A vulnerability in Node.js version 20 allows for bypassing restrictions set by the --experimental-permission flag using the built-in inspector module (node:inspector).\n\nBy exploiting the Worker class's ability to create an \"internal worker\" with the kIsInternal Symbol, attackers can modify the isInternal value when an inspector is attached within the Worker constructor before initializing a new WorkerImpl. This vulnerability exclusively affects Node.js users employing the permission model mechanism.\n\nPlease note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in Node","id":"CVE-2023-30587","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in Node","id":"CVE-2023-30588"},"packages":[{"ecosystem":"Bitnami","fixed":["20.3.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2023-30587"},{"ecosystem":"Bitnami","fixed":["20.3.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2023-30587"}],"prev":{"headline":"Privilege escalation in Node","id":"CVE-2023-30586"},"products":["Node"],"published":"2024-09-07","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Attackers can bypass Node.js experimental permission restrictions via the inspector module, affecting users who enable this experimental feature.","url":"https://insights.sbomify.com/CVE-2023-30587/"}