# CVE-2023-30587: Security feature bypass in Node

> Attackers can bypass Node.js experimental permission restrictions via the inspector module, affecting users who enable this experimental feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2024
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-node-2023-30587, BIT-node-min-2023-30587, GHSA-c595-v5xp-gv8w

## What is CVE-2023-30587?

CVE-2023-30587 is a high-severity vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Node.js version 20 allows for bypassing restrictions set by the --experimental-permission flag using the built-in inspector module (node:inspector).

By exploiting the Worker class's ability to create an "internal worker" with the kIsInternal Symbol, attackers can modify the isInternal value when an inspector is attached within the Worker constructor before initializing a new WorkerImpl. This vulnerability exclusively affects Node.js users employing the permission model mechanism.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-30587?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.3.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.3.1 |

## How do I fix CVE-2023-30587?

Upgrade node to 20.3.1 or later.

## Is CVE-2023-30587 being exploited?

There is no known exploitation of CVE-2023-30587 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30587 and fix it if it is affected.

What it is: CVE-2023-30587 is a high-severity vulnerability in NodeJS Node, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30587 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.3.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30587/ (Markdown: https://insights.sbomify.com/CVE-2023-30587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30587
- OSV: https://osv.dev/vulnerability/CVE-2023-30587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30587/
Summaries are generated and may contain mistakes; the official description above is the record.
