CVE-2023-30601 Apache Cassandra: Privilege escalation when enabling FQL/Audit logs
Users with JMX access can escalate privileges to execute arbitrary commands when FQL or Audit logs are enabled in Apache Cassandra.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-30601?
CVE-2023-30601 is a high-severity vulnerability in Apache Cassandra, published on 30 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1.
WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users.
MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.
Weakness: CWE-269
Which versions are affected by CVE-2023-30601?
5 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | From 4.0.0 | 4.0.10 |
org.apache.cassandra:cassandra-all Maven | From 4.0.0 | 4.0.10 |
org.apache.cassandra:cassandra-all Maven | From 4.1.0 | 4.1.2 |
org.apache.cassandra:cassandra-all Maven | From 4.1.0 | 4.1.2 |
cassandra Bitnami | From 4.0.0 | 4.0.10, 4.1.2 |
Products include Apache Cassandra.
How do I fix CVE-2023-30601?
Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.10 or 4.1.2.
Is CVE-2023-30601 being exploited?
There is no known exploitation of CVE-2023-30601 in the wild and no public exploit code.
Other vulnerabilities in Apache Cassandra
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as BIT-cassandra-2023-30601, GHSA-m9p2-j4hg-g373.