# CVE-2023-30601: Apache Cassandra: Privilege escalation when enabling FQL/Audit logs

> Users with JMX access can escalate privileges to execute arbitrary commands when FQL or Audit logs are enabled in Apache Cassandra.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 9 Oct 2024
- **Also known as:** BIT-cassandra-2023-30601, GHSA-m9p2-j4hg-g373

## What is CVE-2023-30601?

CVE-2023-30601 is a high-severity vulnerability in Apache Cassandra, published on 30 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra
This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1.

WORKAROUND
The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users.

MITIGATION
Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-30601?

5 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0.0 | 4.0.10 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0.0 | 4.0.10 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1.0 | 4.1.2 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1.0 | 4.1.2 |
| `cassandra` | Bitnami | From 4.0.0 | 4.0.10, 4.1.2 |

Products: Apache Cassandra.

## How do I fix CVE-2023-30601?

Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.10 or 4.1.2.

## Is CVE-2023-30601 being exploited?

There is no known exploitation of CVE-2023-30601 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30601 and fix it if it is affected.

What it is: CVE-2023-30601 is a high-severity vulnerability in Apache Cassandra, published on 30 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30601 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.0; fixed in 4.0.10
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.0; fixed in 4.0.10
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1.0; fixed in 4.1.2
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1.0; fixed in 4.1.2
- cassandra (Bitnami): affected from 4.0.0; fixed in 4.0.10, 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30601/ (Markdown: https://insights.sbomify.com/CVE-2023-30601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30601
- OSV: https://osv.dev/vulnerability/CVE-2023-30601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30601/
Summaries are generated and may contain mistakes; the official description above is the record.
