# CVE-2023-30606: Multisite denial of service through unsanitized dynamic dispatch to SiteSetting in Discourse

> Administrators can trigger denial of service in multisite Discourse instances by calling unsanitized SiteSetting methods, affecting the entire cluster.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** BIT-discourse-2023-30606, GHSA-jj93-w3mv-3jvv

## What is CVE-2023-30606?

CVE-2023-30606 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 18 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. In affected versions a user logged as an administrator can call arbitrary methods on the `SiteSetting` class, notably `#clear_cache!` and `#notify_changed!`, which when done on a multisite instance, can affect the entire cluster resulting in a denial of service. Users not running in multisite environments are not affected. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-30606?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions to 3.0.1 | 3.1.0 |

Products: Discourse Discourse.

## How do I fix CVE-2023-30606?

Upgrade discourse to 3.1.0 or later.

## Is CVE-2023-30606 being exploited?

There is no known exploitation of CVE-2023-30606 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30606 and fix it if it is affected.

What it is: CVE-2023-30606 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 18 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30606 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions up to 3.0.1; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30606/ (Markdown: https://insights.sbomify.com/CVE-2023-30606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30606
- OSV: https://osv.dev/vulnerability/CVE-2023-30606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30606/
Summaries are generated and may contain mistakes; the official description above is the record.
