# CVE-2023-30609: matrix-react-sdk vulnerable to HTML injection in search results via plaintext message highlighting

> Attackers can inject HTML into search results via plaintext messages, though CSP prevents script execution, affecting Matrix client users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 3 Feb 2025
- **Also known as:** CLEANSTART-2024-ZD82819, GHSA-xv83-x443-7rmw, openSUSE-SU-2024:12884-1, openSUSE-SU-2024:12895-1

## What is CVE-2023-30609?

CVE-2023-30609 is a medium-severity cross-site scripting vulnerability in matrix-org matrix-react-sdk, published on 25 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

matrix-react-sdk is a react-based SDK for inserting a Matrix chat/VoIP client into a web page. Prior to version 3.71.0, plain text messages containing HTML tags are rendered as HTML in the search results. To exploit this, an attacker needs to trick a user into searching for a specific message containing an HTML injection payload. No cross-site scripting attack is possible due to the hardcoded content security policy. Version 3.71.0 of the SDK patches over the issue. As a workaround, restarting the client will clear the HTML injection.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-30609?

2 open source packages ship an affected version, including matrix-react-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-react-sdk` | npm | All versions | 3.71.0 |
| `matrix-react-sdk` | npm | All versions | 3.71.0 |
| `element-desktop` | openSUSE:Tumbleweed | All versions | 1.11.30-1.1 |
| `element-web` | openSUSE:Tumbleweed | All versions | 1.11.30-1.1 |

Products: Matrix-React-Sdk Project Matrix-React-Sdk.

## How do I fix CVE-2023-30609?

Upgrade matrix-react-sdk to 3.71.0 or later.

## Is CVE-2023-30609 being exploited?

There is no known exploitation of CVE-2023-30609 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org matrix-react-sdk

- [CVE-2023-28103](https://insights.sbomify.com/CVE-2023-28103/): Prototype pollution in matrix-react-sdk (high 8.2)
- [CVE-2023-37259](https://insights.sbomify.com/CVE-2023-37259/): Cross site scripting in Export Chat feature (medium 6.1)
- [CVE-2021-32622](https://insights.sbomify.com/CVE-2021-32622/): File upload local preview can run embedded scripts after user interaction (medium 4.2)
- [CVE-2021-21320](https://insights.sbomify.com/CVE-2021-21320/): User content sandbox can be confused into opening arbitrary documents (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30609 and fix it if it is affected.

What it is: CVE-2023-30609 is a medium-severity cross-site scripting vulnerability in matrix-org matrix-react-sdk, published on 25 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30609 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-react-sdk (npm): affected all versions; fixed in 3.71.0
- matrix-react-sdk (npm): affected all versions; fixed in 3.71.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30609/ (Markdown: https://insights.sbomify.com/CVE-2023-30609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30609
- OSV: https://osv.dev/vulnerability/CVE-2023-30609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30609/
Summaries are generated and may contain mistakes; the official description above is the record.
