# CVE-2023-30613: Kiwi TCMS unrestricted file upload vulnerability

> Attackers can upload malicious files like executables or scripts to Kiwi TCMS, potentially causing code execution on victim machines.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2023
- **Updated:** 4 Feb 2025
- **Also known as:** GHSA-fwcf-753v-fgcj, PYSEC-2026-1498

## What is CVE-2023-30613?

CVE-2023-30613 is a high-severity vulnerability in kiwitcms Kiwi, published on 24 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kiwi TCMS, an open source test management system, allows users to upload attachments to test plans, test cases, etc. In versions of Kiwi TCMS prior to 12.2, there is no control over what kinds of files can be uploaded. Thus, a malicious actor may upload an `.exe` file or a file containing embedded JavaScript and trick others into clicking on these files, causing vulnerable browsers to execute malicious code on another computer.

Kiwi TCMS v12.2 comes with functionality that allows administrators to configure additional upload validator functions which give them more control over what file types are accepted for upload. By default `.exe` are denied. Other files containing the `<script>` tag, regardless of their type are also denied b/c they are a path to XSS attacks. There are no known workarounds aside from upgrading.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-30613?

3 open source packages ship an affected version, including kiwitcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kiwitcms` | PyPI | All versions | 12.2 |
| `kiwitcms` | PyPI | All versions | 12.2 |
| `kiwitcms` | PyPI | All versions | 12.2 |

Products: Kiwitcms Kiwi Tcms.

## How do I fix CVE-2023-30613?

Upgrade kiwitcms to 12.2 or later.

## Is CVE-2023-30613 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30613 exists.

## Other vulnerabilities in kiwitcms Kiwi

- [CVE-2023-30628](https://insights.sbomify.com/CVE-2023-30628/): Kiwi TCMS has command injection vulnerability in changelog.yml CI workflow (high 8.8)
- [CVE-2023-36809](https://insights.sbomify.com/CVE-2023-36809/): Kiwi TCMS's misconfigured HTTP headers allow stored XSS execution with Firefox (high 8.1)
- [CVE-2023-33977](https://insights.sbomify.com/CVE-2023-33977/): Stored cross site scripting (XSS) via unrestricted file upload in Kiwi TCMS (high 8.1)
- [CVE-2023-32686](https://insights.sbomify.com/CVE-2023-32686/): kiwitcms vulnerable to stored XSS via unrestricted files upload (high 8.1)
- [CVE-2023-27489](https://insights.sbomify.com/CVE-2023-27489/): Stored cross site scripting via SVG file upload in Kiwi TCMS (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30613 and fix it if it is affected.

What it is: CVE-2023-30613 is a high-severity vulnerability in kiwitcms Kiwi, published on 24 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30613 exists.

Affected packages and fixed versions:
- kiwitcms (PyPI): affected all versions; fixed in 12.2
- kiwitcms (PyPI): affected all versions; fixed in 12.2
- kiwitcms (PyPI): affected all versions; fixed in 12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30613/ (Markdown: https://insights.sbomify.com/CVE-2023-30613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30613
- OSV: https://osv.dev/vulnerability/CVE-2023-30613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30613/
Summaries are generated and may contain mistakes; the official description above is the record.
