CVE-2023-30614 Improper Neutralization of Script-Related HTML Tags in a Web Page in pay

High 7.1 Published Updated

Reflected XSS in Pay payments engine allows attackers to execute scripts via crafted URLs, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-30614?

CVE-2023-30614 is a high-severity cross-site scripting vulnerability in pay-rails pay, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2023-30614?

2 open source packages ship an affected version, including pay. It affects 1 product.

PackageAffectedFixed in
pay RubyGemsAll versions6.3.2
pay RubyGemsAll versions6.3.2

Products include Pay Project Pay.

How do I fix CVE-2023-30614?

Upgrade pay to 6.3.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-30614 being exploited?

There is no known exploitation of CVE-2023-30614 in the wild and no public exploit code.

Sources

Also known as GHSA-cqf3-vpx7-rxhw.

Is CVE-2023-30614 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free