{"answers":{"affected":"2 open source packages ship an affected version, including pay. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30614 in the wild and no public exploit code.","fix":"Upgrade pay to 6.3.2 or later.","what":"CVE-2023-30614 is a high-severity cross-site scripting vulnerability in pay-rails pay, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-30614 and fix it if it is affected.\n\nWhat it is: CVE-2023-30614 is a high-severity cross-site scripting vulnerability in pay-rails pay, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-30614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pay (RubyGems): affected all versions; fixed in 6.3.2\n- pay (RubyGems): affected all versions; fixed in 6.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30614/ (Markdown: https://insights.sbomify.com/CVE-2023-30614/index.md)","id":"CVE-2023-30614","markdown":"https://insights.sbomify.com/CVE-2023-30614/index.md","name":"CVE-2023-30614","record":{"aliases":["GHSA-cqf3-vpx7-rxhw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails payments engine","requires_auth":"none","summary":"Reflected XSS in Pay payments engine allows attackers to execute scripts via crafted URLs, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pay","vendor":"pay_project"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page in pay","id":"CVE-2023-30614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in iris-web","id":"CVE-2023-30615"},"packages":[{"ecosystem":"RubyGems","fixed":["6.3.2"],"introduced":["0"],"last_affected":[],"package":"pay","purl":null,"source":"GHSA-cqf3-vpx7-rxhw"},{"ecosystem":"RubyGems","fixed":["6.3.2"],"introduced":["0"],"last_affected":[],"package":"pay","purl":"pkg:gem/pay","source":"GHSA-cqf3-vpx7-rxhw"}],"prev":{"headline":"Kiwi TCMS unrestricted file upload vulnerability","id":"CVE-2023-30613"},"products":["pay"],"published":"2023-04-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-05","vendors":["pay-rails"]},"summary":"Reflected XSS in Pay payments engine allows attackers to execute scripts via crafted URLs, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2023-30614/"}