# CVE-2023-30614: Improper Neutralization of Script-Related HTML Tags in a Web Page in pay

> Reflected XSS in Pay payments engine allows attackers to execute scripts via crafted URLs, potentially leading to session hijacking or data theft.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-cqf3-vpx7-rxhw

## What is CVE-2023-30614?

CVE-2023-30614 is a high-severity cross-site scripting vulnerability in pay-rails pay, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-30614?

2 open source packages ship an affected version, including pay. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pay` | RubyGems | All versions | 6.3.2 |
| `pay` | RubyGems | All versions | 6.3.2 |

Products: Pay Project Pay.

## How do I fix CVE-2023-30614?

Upgrade pay to 6.3.2 or later.

## Is CVE-2023-30614 being exploited?

There is no known exploitation of CVE-2023-30614 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30614 and fix it if it is affected.

What it is: CVE-2023-30614 is a high-severity cross-site scripting vulnerability in pay-rails pay, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30614 in the wild and no public exploit code.

Affected packages and fixed versions:
- pay (RubyGems): affected all versions; fixed in 6.3.2
- pay (RubyGems): affected all versions; fixed in 6.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30614/ (Markdown: https://insights.sbomify.com/CVE-2023-30614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30614
- OSV: https://osv.dev/vulnerability/CVE-2023-30614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30614/
Summaries are generated and may contain mistakes; the official description above is the record.
