{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30616 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-30616 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-30616 is a medium-severity vulnerability in epiphyt form-block, published on 20 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-30616 and fix it if it is affected.\n\nWhat it is: CVE-2023-30616 is a medium-severity vulnerability in epiphyt form-block, published on 20 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-30616 in the wild and no public exploit code.\n\nAffected product: epiphyt form-block. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30616/ (Markdown: https://insights.sbomify.com/CVE-2023-30616/index.md)","id":"CVE-2023-30616","markdown":"https://insights.sbomify.com/CVE-2023-30616/index.md","name":"CVE-2023-30616","record":{"aliases":["GHSA-j4c2-7p87-q824"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can force users to submit form data without consent due to missing nonce verification in the Form Block plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"form_block","vendor":"epiph"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Form block is a wordpress plugin designed to make form creation easier. Versions prior to 1.0.2 are subject to a Cross-Site Request Forgery due to a missing nonce check. There is potential for a Cross Site Request Forgery for all form blocks, since it allows to send requests to the forms from any website without a user noticing. Users are advised to upgrade to version 1.0.2. There are no known workarounds for this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Cross Site Request Forgery due to missing nonce verification in form block","id":"CVE-2023-30616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Leverage the kruise-daemon pod to list all secrets in the entire cluster","id":"CVE-2023-30617"},"packages":[],"prev":{"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in iris-web","id":"CVE-2023-30615"},"products":["form-block"],"published":"2023-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-04","vendors":["epiphyt"]},"summary":"Attackers can force users to submit form data without consent due to missing nonce verification in the Form Block plugin.","url":"https://insights.sbomify.com/CVE-2023-30616/"}