# CVE-2023-30617: Leverage the kruise-daemon pod to list all secrets in the entire cluster

> An attacker with root access on a node can use kruise-daemon to list all cluster secrets and escalate privileges via service account tokens.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2024
- **Updated:** 16 Jun 2025
- **Also known as:** GHSA-437m-7hj5-9mpw

## What is CVE-2023-30617?

CVE-2023-30617 is a medium-severity vulnerability in openkruise kruise, published on 3 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kruise provides automated management of large-scale applications on Kubernetes. Starting in version 0.8.0 and prior to versions 1.3.1, 1.4.1, and 1.5.2, an attacker who has gained root privilege of the node that kruise-daemon run can leverage the kruise-daemon pod to list all secrets in the entire cluster. After that, the attacker can leverage the "captured" secrets (e.g. the kruise-manager service account token) to gain extra privileges such as pod modification. Versions 1.3.1, 1.4.1, and 1.5.2 fix this issue. A workaround is available. For users that do not require imagepulljob functions, they can modify kruise-daemon-role to drop the cluster level secret get/list privilege.

Weakness: CWE-269 (Improper Privilege Management), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2023-30617?

6 open source packages ship an affected version, including github.com/openkruise/kruise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openkruise/kruise` | Go | From 0.8.0 | 1.3.1 |
| `github.com/openkruise/kruise` | Go | From 0.8.0 | 1.3.1 |
| `github.com/openkruise/kruise` | Go | From 1.4.0 | 1.4.1 |
| `github.com/openkruise/kruise` | Go | From 1.4.0 | 1.4.1 |
| `github.com/openkruise/kruise` | Go | From 1.5.0 | 1.5.2 |
| `github.com/openkruise/kruise` | Go | From 1.5.0 | 1.5.2 |

Products: Openkruise Kruise.

## How do I fix CVE-2023-30617?

Upgrade github.com/openkruise/kruise to a fixed version for your release line: 1.3.1, 1.4.1 or 1.5.2.

## Is CVE-2023-30617 being exploited?

There is no known exploitation of CVE-2023-30617 in the wild and no public exploit code.

## Other vulnerabilities in openkruise kruise

- [CVE-2026-24005](https://insights.sbomify.com/CVE-2026-24005/): OpenKruise PodProbeMarker is Vulnerable to SSRF via Unrestricted Host Field (not scored)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30617 and fix it if it is affected.

What it is: CVE-2023-30617 is a medium-severity vulnerability in openkruise kruise, published on 3 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30617 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openkruise/kruise (Go): affected from 0.8.0; fixed in 1.3.1
- github.com/openkruise/kruise (Go): affected from 0.8.0; fixed in 1.3.1
- github.com/openkruise/kruise (Go): affected from 1.4.0; fixed in 1.4.1
- github.com/openkruise/kruise (Go): affected from 1.4.0; fixed in 1.4.1
- github.com/openkruise/kruise (Go): affected from 1.5.0; fixed in 1.5.2
- github.com/openkruise/kruise (Go): affected from 1.5.0; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30617/ (Markdown: https://insights.sbomify.com/CVE-2023-30617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30617
- OSV: https://osv.dev/vulnerability/CVE-2023-30617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30617/
Summaries are generated and may contain mistakes; the official description above is the record.
